1. 首页 > 常识

通达信天一神鞭指标公式-通达信公式 通达信常用指标公式大全

本文为大家介绍了 通达信天一神鞭指标公式-通达信公式 ,还有的小伙伴在问通达信常用指标公式大全,下面小编给大家细致的讲述一下。

动态止损度:=5;

黑:=0;{下跌通道黑色K线开关}

离L:=0;{乖离提示开关}

提示:=0;{买卖文字提示开关}

布林M:=0;{开关}

MMA:=0;

五:MA(CLOSE,5),COLORWHITE;

十:MA(CLOSE,10),COLOR00FFFF;

M18:=MA(CLOSE,18),COLORRED;

离基:=五;

离O:=离基*1.20,COLOR555555;

离A:离基*1.15,COLOR555555;

离B:离基*1.10,COLOR555555;

离C:离基*0.90,COLOR555555;

离D:=离基*0.85,COLOR333333;

EXP50:=EXPMA(CLOSE,50),COLORGREEN;

MA30:MA(CLOSE,30),LINETHICK1,COLORRED;

MA60:MA(CLOSE,60),COLORGREEN;

β0:=(H-L)/2+L,LINETHICK0;

α:=β0,LINETHICK0;

β:=REF(β0,1),LINETHICK0,COLORGREEN;

γ:=REF(β0,2),LINETHICK0,COLORMAGENTA;

{涨:PLOYLINE(C>REF(C,1),CONST(C)),COLOR0000AA,LINETHICK1;

跌:PLOYLINE(C<REF(C,1),CONST(C)),COLOR00AA00,LINETHICK1;}

高:PLOYLINE(1,CONST(HHV(H,50))),COLOR770077,LINETHICK1;

低:=PLOYLINE(1,CONST(LLV(L,50))),COLOR777700,LINETHICK1;

中:=PLOYLINE(1,(高-低)/2+低),COLOR005555,LINETHICK4;

止损价:=CONST(HHV(C,5)*(100-动态止损度)/100);

止:PLOYLINE(CONST(C)<=止损价,止损价),COLOR888800,LINETHICK4;

DRAWTEXT(DYNAINFO(7)<=止损价 AND ISLASTBAR,止损价*1.05,"止损");

AA:=CLOSE/REF(C,1)>=1.09;

BA:=CLOSE/REF(C,1)>=1.09;

DRAWKLINE(H,O,L,C);

STICKLINE(AA,O,C,2.5,1),COLORYELLOW;

MA1:=MA(CLOSE,5),COLORRED;

MA2:=MA(CLOSE,10),COLORYELLOW;

MA3:=MA(CLOSE,20),COLOR770077;

E50:=EXPMA(CLOSE,50),LINETHICK1,POINTDOT,COLORLIGREEN;

E100:=EXPMA(CLOSE,100),POINTDOT,COLORGRAY;

MA181:MA(C,181),COLORGRAY;

{MA60:=MA(C,60),COLOR007700;}

{周:IF( MMA=1 ,MA2,DRAWNULL),COLORYELLOW,LINETHICK1;

月:IF( MMA=1 ,MA3,DRAWNULL),COLORWHITE,LINETHICK1;

季:IF( MMA=1 ,MA4,DRAWNULL),COLORGREEN,LINETHICK1;}

{IF(C>E50 ,E50,DRAWNULL),COLOR00FF00,LINETHICK1;}

IF(CONST(α>β) AND DYNAINFO(7)>0,DYNAINFO(7),DRAWNULL),COLOR000088,LINETHICK1;

IF(CONST(α<=β)AND DYNAINFO(7)>0 ,DYNAINFO(7),DRAWNULL),COLOR008800,LINETHICK1;

IF(CONST(α>β) AND DYNAINFO(7)>0 AND DYNAINFO(7)>=高*0.99,DYNAINFO(7),DRAWNULL),COLOR000088,LINETHICK1;

IF(CONST(α<=β)AND DYNAINFO(7)>0 AND DYNAINFO(7)<=低*1.01 ,DYNAINFO(7),DRAWNULL),COLOR008800,LINETHICK1;

N1:=12;

N2:=26;

N3:=9;

DIFF:=(EMA(CLOSE,N1) - EMA(CLOSE,N2));

DEA:=EMA(DIFF,N3);

MACD:=(2 * (DIFF - DEA));

MACD2:=MACD;

SARH:=CLOSE>SAR(4,2,20);

{IF(C<MA3 ,MA1,DRAWNULL),COLOR555555,LINETHICK1;}

{IF(C<MA3 ,MA2,DRAWNULL),COLOR222222,LINETHICK1;}

{IF(五>=REF(五,1) ,离A,DRAWNULL),COLOR0000FF,LINETHICK1;

IF(五>=REF(五,1) ,离B,DRAWNULL),COLOR0000FF,LINETHICK1;

IF(五<=REF(五,1) ,离C,DRAWNULL),COLOR00FF00,LINETHICK1;

IF(五<=REF(五,1) ,离D,DRAWNULL),COLOR00FF00,LINETHICK1;}

五V:=MA(V,5);

{IF(五V>=REF(五V,1) ,离A,DRAWNULL),COLOR0000FF,LINETHICK1;

IF(五V>=REF(五V,1) ,离B,DRAWNULL),COLOR0000FF,LINETHICK1;

IF(五V<=REF(五V,1) ,离C,DRAWNULL),COLOR00FF00,LINETHICK1;

IF(五V<=REF(五V,1) ,离D,DRAWNULL),COLOR00FF00,LINETHICK1;}

{IF(五<REF(五,2) AND 离L=0,离A,DRAWNULL),COLOR555555,LINETHICK1;

IF(五<REF(五,2) AND 离L=0,离D,DRAWNULL),COLOR555555,LINETHICK1;}

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

STICKLINE(C<MA3 AND 黑=1,H,L,0,0),COLOR555555;

STICKLINE(MA1<MA3 AND 黑=1,O,C,2.5,1),COLOR555555;

STICKLINE(BA AND C<MA3,O,C,2.7,1),COLORWHITE;

{DRAWICON(MACD>REF(MACD,1) AND CROSS(C,MA3) AND 提示=0 ,L,1);}

{DRAWICON(REF(C>MA3 AND 提示,1) AND CROSS(MA(C,5),C),H,2);}

N:=14;

M:=6;

TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

HD :=HIGH-REF(HIGH,1);

LD :=REF(LOW,1)-LOW;

DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);

DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);

PDI:=DMP*100/TR;

MDI:=DMM*100/TR;

ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);

ADXR:=EXPMEMA(ADX,M);

DMIJX:=CROSS(PDI,MDI) AND C>O ;

{STICKLINE(DMIJX,H,L,0,1),COLORYELLOW;

STICKLINE(DMIJX,O,C,2.7,0),COLORYELLOW;}

{DRAWICON(DMIJX AND 提示=0,L,1);}

{DRAWTEXT(H>离A,离A/0.99,"★"),COLORYELLOW;}

头上边:=MAX(O,C),NODRAW;

头下边:=MIN(O,C),NODRAW;

垂头:=ABS(O-C),NODRAW;{垂头}

长针:=(头下边-L),NODRAW;{长针}

垂:=长针/垂头>2 AND (H-头上边)<=长针 AND L<REF(L,1) AND O<REF(C,1),NODRAW;

DRAWTEXT(垂 AND L<=LLV(L,3) AND L<离C AND 提示,L/1.01,"针") AND 提示,COLORGREEN,LINETHICK4;

DRAWTEXT(H>MA(CLOSE,5)*1.07 AND ISLASTBAR AND 提示,H*1.01,"离!"),COLORGREEN,LINETHICK2;

DRAWTEXT(L<MA(CLOSE,5)*1.005 AND L>MA(CLOSE,5) AND 提示=0 AND H<MA(CLOSE,5)*1.07 AND ISLASTBAR,L/1.02,"低吸"),COLORGREEN,LINETHICK2;

{////MACD反身向上////}

{MACD红缩:=REF(MACD,1)>MACD AND MACD>0;

DRAWTEXT(REF(EVERY(MACD红缩,3),1)

AND MACD>REF(MACD,1) AND C>MA(C,22) AND 提示=0,L/1.02,"启动"),COLORWHITE;

}

{////MACD反身向上2////}

{MACD红缩2:=REF(MACD,1)>MACD AND MACD>0;

DRAWTEXT(REF(EVERY(MACD红缩2,2),1)

AND MACD>REF(MACD,1) AND C>MA(C,22) AND EVERY(DIFF>0,3) AND 提示=0,L/1.02,"起动"),COLORWHITE;

}

{突破买进(源码)}

{DRAWTEXT(DYNAINFO(7)>0 AND ISLASTBAR ,HIGH,"("DYNAINFO(7)")");}

上5日:=REF(EVERY(C<MA1,2),1) AND CROSS(C,MA1);

STICKLINE(上5日,H,L,0,0),COLORFF00FF;

{STICKLINE(上5日,O,C,2.7,0),COLOR3366FF;}

STICKLINE(上5日,O,C,2.7,0),COLORFF00FF;

DRAWICON(上5日,L,1);

破5日:=REF(EVERY(C>MA1,4),1) AND CROSS(MA1,C);

DRAWICON(破5日,H,2);

DT:=REF(CLOSE/REF(C,1),1)<=0.95;

DRAWTEXT(AA AND DT AND CURRBARSCOUNT<60 ,H,"急挖坑"),COLORGREEN;

SC1:=MACD.MACD<0;

SC2:=CROSS(十,五);

SC3:=MA(V,5)<MA(V,10);

SC:=SC1 AND SC2 AND SC3 ;

DRAWTEXT(SC AND CURRBARSCOUNT<10 ,HHV(H,5),"三死叉"),COLORWHITE;

JC1:=MACD.MACD>0;

JC2:=CROSS(五,十);

JC3:=MA(V,5)>MA(V,10);

JC:=JC1 AND JC2 AND JC3 ;

DRAWTEXT(JC AND CURRBARSCOUNT<20 ,LLV(L,5),"后金叉"),COLORYELLOW;

{ZS:=CROSS(DMI.ADXR,DMI.ADX);

DRAWTEXT(ZS AND CURRBARSCOUNT<10 ,HHV(H,5),"转势"),COLORRED;}

{IF(五<REF(五,1),五,DRAWNULL),COLOR888888,LINETHICK1;};

{XQK:=H<REF(L,1) ;

DRAWTEXT(XQK AND CURRBARSCOUNT<20 ,H,"□□□□□□□□□□□□"),COLOR999999;

SQK:= L>REF(H,1);

DRAWTEXT(SQK AND CURRBARSCOUNT<20 ,L,"□□□□□□□□□□□□"),COLORRED;};

DRAWTEXT(CROSS(H,离B) AND CURRBARSCOUNT<10 ,HHV(H,3),"超乖离"),COLORYELLOW;

DRAWTEXT(CROSS(H,离A) AND CURRBARSCOUNT<10 ,HHV(H,3),"超乖离"),COLORYELLOW;

DRAWTEXT(CROSS(离C,L) AND CURRBARSCOUNT<10 ,LLV(L,3),"负乖离"),COLORWHITE;

DRAWTEXT((C<MA(C,5) OR MA(C,5)<MA(C,10)) AND CURRBARSCOUNT<2,HHV(H,5)*1.04,"MA5下"),COLORRED;

DRAWTEXT((C<MA(C,5) OR MA(C,5)<MA(C,10)) AND CURRBARSCOUNT<2 ,HHV(H,5)*1.01,"不持股"),COLORRED;

 通达信天一神鞭指标公式-通达信公式  通达信常用指标公式大全

通达信常用指标公式大全

可以编写搓揉选股公式前一天长上影线当日长下影线并且两条的长度都大于3%以上的通达信选股公式.

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIF,9);MACD:=(DIF-DEA)*2;忽略以上公式. 根据思路编写公式,修改公式.盘中预警,条件选股.公式解密,去除时间限制.鼠标点击下方 我 的 名 字 或(图 标)上,进入 可 看到 Q,订 制 公式

1)REF(C,1)>REF(O,1) AND REF(H,1)/REF(C,1)>1.02 AND REF(H,1)/REF(L,1))>1.. 以上就是你想要的公式,希望对你帮助.(你选择的一些用词不够量化,比如长下影线.