1. 首页 > 常识

通达信股海狂龙指标公式-通达信公式 神奇k线组合主图指标

本文为大家介绍了 通达信股海狂龙指标公式-通达信公式 ,还有的小伙伴在问神奇k线组合主图指标,下面小编给大家细致的讲述一下。

现价:=C*3,COLORRED;

顶部:= COST(95) ,COLORFFFF33;

卖出:= COST(75)*3 ,COLORGREEN;

买入:= COST(30) ,COLORRED;

底部:= COST(5) ;

空:=EMA(C,5);

均衡:=EMA(空,5),COLORWHITE;

中轨:=HHV(MA(H,13),13),COLORRED,LINETHICK2;

趋势:=LLV(MA(H,13),1),COLOR00FF00,LINETHICK2;

HHH:=(CROSS(均衡,趋势))*5;

CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;

YJD:= (EMA(CS,3)-50)*2;

筹码集中度:=COST(10)/(COST(80)-COST(10));

筹码1:=EMA(筹码集中度,1)*10,LINETHICK2,COLOR3399FF;

筹码3:=EMA(筹码集中度,3)*10,LINETHICK2,COLORRED;

买线:=EMA(C,2);

卖线:=EMA(SLOPE(C,21)*20+C,42);

BU:=CROSS(买线,卖线);

SEL:=CROSS(卖线,买线);

{DRAWICON(BU =1,L-0.1,1);}

N:=15;M:=20;

TR:=EXPMEMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),N);

HD:=H-REF(H,1);

LD:=REF(L,1)-L;

DMP:=EXPMEMA(IF(HD>0 AND HD>LD,HD,0),N);

DMM:=EXPMEMA(IF(LD>0 AND LD>HD,LD,0),N);

VAR1:=DMP*100/TR;

VAR2:=DMM*100/TR;

VARR3:=EXPMEMA(VAR1,M);

VARR4:=EXPMEMA(VAR2,M);

{DRAWBAND(VAR3,RGB(150,30,50),VAR4,RGB(30,110,50));}

PDI:=VAR1,COLORYELLOW;

MDI:=VAR2,COLORGREEN;

{STICKLINE(VAR1>VAR3 AND VAR2<VAR3,VAR3,VAR1,0,0.5),COLORWHITE;}

涨:=(VAR1>VARR3) AND (VAR2<VARR3),COLORWHITE;

顶:=85;

中:=50;

底:=20;

VA1:=HHV(HIGH,9)-LLV(LOW,9);

VA2:=HHV(HIGH,9)-CLOSE;

VA3:=CLOSE-LLV(LOW,9);

VA4:=VA2/VA1*100-70;

VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

VA6:=(2*CLOSE+HIGH+LOW)/4;

VA7:=SMA(VA3/VA1*100,3,1);

VA8:=LLV(LOW,34);

VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);

VAA:=IF(VA9>100,VA9-100,0);

VAB:=HHV(HIGH,34);

AAA:= VAA*2;

BBB:= EMA((VA6-VA8)/(VAB-VA8)*100,13);

VAC:=EMA(0.667*REF(BB,1)+0.333*BB,2);

CCC:=SMA(VA5,20,1),COLORRED;

CCC1:=SMA(CCC,5,1),COLORGREEN;

出:=IF((CROSS(CCC,CCC1) AND (CCC1 < 顶) ),80,0)/23,COLORRED;

VOLUME:=VOL,VOLSTICK;

主力启动线:=MA(VOLUME,5),COLORRED,LINETHICK2;

主力洗盘线:=MA(VOLUME,35),COLORYELLOW,LINETHICK2;

资金异动线:=MA(VOLUME,135),COLORBLUE,LINETHICK2;

击:=STICKLINE(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线)

AND CROSS(主力启动线,主力洗盘线)),0,VOL,2,0),COLORYELLOW;

动:=STICKLINE(主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线)

AND (REF(VOL,1)<REF(资金异动线,1) AND REF(VOL,2)<REF(资金异动线,2)))

,0,VOL,3,0),COLORGREEN;

V1:=CLOSE/REF(CLOSE,3)>=1.1;

V2:=BACKSET(V1,2);

V3:=REF(CLOSE,3)*1.1;

V4:=CROSS(C,V3);

OK:=STICKLINE((V2 AND COUNT(V2,2)=1),VOL,0,3,0),COLORRED;

BOLLL:=MA(CLOSE,20),COLORRED;

UP:=BOLLL+2*STD(CLOSE,20),COLOR808080 ;

LO:=BOLLL-2*STD(CLOSE,20),COLORGREEN;

DSLX:=((CLOSE/INDEXC)*10000),COLORFFFFFF,;

DSLXMA1:=MA(DSLX,5),COLOR0000FF;

DSLXMA2:=MA(DSLX,10),COLOR00FF00;

DSLXMA3:=MA(DSLX,0);DSLXMA4:=MA(DSLX,0);

DI:(EMA(CLOSE,3)-EMA(CLOSE,13))*2,COLORBLUE,LINETHICK2;

D1:=EMA(DI,5),COLORGRAY;

D2:=EMA(DI,10),COLORGRAY;

D3:=EMA(DI,20),COLORGRAY;

D4:=EMA(DI,30),COLORGRAY;

D5:=EMA(DI,60),COLORGRAY;

D6:=EMA(DI,90),COLORGRAY;

D7:=EMA(DI,120),COLORGRAY;

D8:=EMA(DI,250),COLORGRAY;

AA:STICKLINE(DI>=REF(DI,1) AND D1>=REF(D1,1) AND D2>=REF(D2,1) AND D3>=REF(D3,1) AND

D4>=REF(D4,1) AND D5>=REF(D5,1) AND D6>=REF(D6,1) AND D7>=REF(D7,1) AND

D8>=REF(D8,1) AND C>EMA(C,11) AND DI>-0.8,DI,0,2,0)*2,COLORRED;

0,LINETHICK2;

VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

VAR6:=(VAR3+VAR4+VAR5)/3;

VAR7:=EMA(VAR6,5);

RSVV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSVV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

日均价:=(C*3+H+L+O)/6;

JF1:=SMA(SMA(EMA(日均价,5)*2-MA(日均价,5),3,1),3,1),COLOR999900;

补偿:=FLOOR(((JF1-MA(JF1,5))/MA(JF1,5)*100));

风:=SMA(SMA((EMA(日均价,(5+ABS(补偿)))),2,1),2,1),COLORWHITE,LINETHICK2;

上轨:=风+2*STD(风,10),COLORBLUE;

下轨:=风-2*STD(风,10),COLORBLUE;

无盐:=EMA(日均价,5)*2-MA(日均价,5);

修正:=SMA(SMA(EMA(日均价,5)*2-MA(日均价,5),2,1),2,1),COLOR999900;

夺命:=(MA(C,5)+MA(C,13))/2;

追风:=MA(C,5)-MA(C,13)+MA(C,8),COLORRED,LINETHICK2;

UU:=(3*C+H+2*O)/6;

DSSA:=SMA(XMA(UU,2),2,1),LINETHICK2;

部:=DSSA*1,COLORYELLOW;

BOLL:=(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)

-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),13,1))/(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)

-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),5,1));

{A1:BOLL+2*STD(CLOSE,1);

B1:BOLL-2*STD(CLOSE,1);}

魔花A2:BOLL+2*STD(CLOSE,3);

B2:BOLL-2*STD(CLOSE,3);

{A3:BOLL+2*STD(CLOSE,5);

B3:BOLL-2*STD(CLOSE,5);}

A4:BOLL+2*STD(CLOSE,7);

B4:BOLL-2*STD(CLOSE,7);

A5:BOLL+2*STD(CLOSE,9);

B5:BOLL-2*STD(CLOSE,9);

A6:BOLL+2*STD(CLOSE,11);

B6:BOLL-2*STD(CLOSE,11);

A7:BOLL+2*STD(CLOSE,13);

B7:BOLL-2*STD(CLOSE,13);

A8:BOLL+2*STD(CLOSE,15);

B8:BOLL-2*STD(CLOSE,15);

A9:BOLL+2*STD(CLOSE,17);

B9:BOLL-2*STD(CLOSE,17);

A10:BOLL+2*STD(CLOSE,19);

B10:BOLL-2*STD(CLOSE,19);

{A11:BOLL+2*STD(CLOSE,21);

B11:BOLL-2*STD(CLOSE,21);}

{A12:BOLL+2*STD(CLOSE,23);

B12:BOLL-2*STD(CLOSE,23);}

A13:BOLL+2*STD(CLOSE,2);

B13:BOLL-2*STD(CLOSE,2);

A14:BOLL+2*STD(CLOSE,4);

B14:BOLL-2*STD(CLOSE,4);

A15:BOLL+2*STD(CLOSE,6);

B15:BOLL-2*STD(CLOSE,6);

A16:BOLL+2*STD(CLOSE,8);

B16:BOLL-2*STD(CLOSE,8);

A17:BOLL+2*STD(CLOSE,10);

B17:BOLL-2*STD(CLOSE,10);

A18:BOLL+2*STD(CLOSE,12);

B18:BOLL-2*STD(CLOSE,12);

A19:BOLL+2*STD(CLOSE,14);

B19:BOLL-2*STD(CLOSE,14);

A20:BOLL+2*STD(CLOSE,16);

B20:BOLL-2*STD(CLOSE,16);

A21:BOLL+2*STD(CLOSE,18);

B21:BOLL-2*STD(CLOSE,18);

{A22:BOLL+2*STD(CLOSE,20);

B22:BOLL-2*STD(CLOSE,20);}

A23:BOLL+1.6*STD(CLOSE,22),COLORYELLOW, LINETHICK1;

B23:BOLL-1.6*STD(CLOSE,22),COLORYELLOW, LINETHICK1;

{A25:BOLL+2*STD(CLOSE,25), COLORYELLOW,LINETHICK1.5;

B25:BOLL-2*STD(CLOSE,25), COLORYELLOW,LINETHICK1.5;}

{2.5,COLORFF4242;}

2,COLORGREEN,LINETHICK2;

{0.5,COLORFFCC66;

1.5,COLORFFCC66;}

0,COLORGREEN,LINETHICK2;

(-1.5),COLORFF4242;

4,COLORYELLOW,LINETHICK2;

{5,COLORYELLOW;}

{6,COLORYELLOW;}

强弱线:6.5*MA(((C+L+(H+C)/2)/3-LLV(L,13)) /(HHV(H,13)-LLV(L,13)),3),COLORRED;

辅助线:6.5*((C+L+(H+C)/2)/3-LLV(L,21))/(HHV(H,21)-LLV(L,21)),COLORFFFFFA;

MA1:=MA(CLOSE,5);

MA2:=MA(CLOSE,13);

MA3:=MA(CLOSE,34);

MA4:=MA(CLOSE,60);

MA5:=MA(C,120);

MA6:=MA(C,250);

DIF:=EMA(CLOSE,40)-EMA(CLOSE,41);

DEA:=EMA(DIF,6);

MACD:=(DIF-DEA)*6,COLORSTICK;

WR:=100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34));

PSY:=COUNT(CLOSE>REF(CLOSE,1),13)/13*100;

AR:=SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100;

ROC:=100*(CLOSE-REF(CLOSE,12))/REF(CLOSE,12);

MCST:=DMA(AMOUNT/(100*VOL),VOL/CAPITAL),COLORCYAN;

RSV:=(((CLOSE - LLV(LOW,33)) / (HHV(HIGH,33) - LLV(LOW,33))) * 100);

Y0:=SMA(RSV,7,1)/4;

Y1:=SMA(SMA(RSV,7,1),4,1)/4;

Y3:=SMA(SMA(SMA(RSV,7,1),4,1),6,1)/4;

根:=( ((辅助线<1.5) AND (A23>1.5)AND (B23>0.5) AND (A23<2.2))

OR (强弱线<2 AND (A23>1.5)AND (B23>0.4) AND (A23<2.2)AND(辅助线>2.5)

AND(O+C*3+L)/5>MA3)

OR (强弱线<2 AND (A23>1)AND (B23>0.5) AND (A23<1.8)AND(辅助线>2.5)

AND(O+C*3+L)/5>MA3))*2

,COLORGREEN,LINETHICK3;

花种:=((DI>0 AND DI<0.8 AND (DI>=REF(DI,1) AND D1>=REF(D1,1) AND D2>=REF(D2,1) AND D3>=REF(D3,1) AND

D4>=REF(D4,1) AND D5>=REF(D5,1) AND D6>=REF(D6,1) AND D7>=REF(D7,1) AND

D8>=REF(D8,1) AND C>EMA(C,11) ) AND 3<(辅助线+强弱线)/2)

AND (MA1/MA2)<1.028 AND MA1>风 AND C/O<1.05 AND REF(C,1)/REF(C,2)<1.068

AND VOL/REF(VOL,1)<5 )

, COLORYELLOW,LINETHICK2;

JJJ:=(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线)

AND CROSS(主力启动线,主力洗盘线)))*4,COLORYELLOW;

DDD:=((主力启动线>REF(主力启动线,1)) AND CROSS(VOL,主力启动线)

AND (REF(VOL,1)<REF(资金异动线,1)) AND REF(VOL,2)<REF(资金异动线,2))*4

,COLORGREEN;

KKK:=((V2 AND COUNT(V2,2)=1))*4,COLORRED;

含苞欲放:((DDD=4 AND 花种>0) OR (BU AND 花种>0 ) )*2.3,COLORMAGENTA,LINETHICK2;

LONG2:(CROSS(DI,0.5) AND MA2>MA3 AND MA3>MA4

AND 部/风<1.05 AND 部>REF(部,1) AND 部>上轨)*1.5

,COLORYELLOW ,LINETHICK2;

吐蕊:(JJJ=4 AND 花种>0 AND LONG2>0 ) *1.8,COLORYELLOW,LINETHICK2;

怒放:(吐蕊>0 AND 含苞欲放>0)

*3.5,COLORRED,LINETHICK2;

ZF:=(C/REF(C,1)-1)*100;

势:=SUM(ZF,3),COLORFFFFFF,LINETHICK2;

RO:=(100*(CLOSE-REF(CLOSE,12))/REF(CLOSE,12));

OKK:=EMA((ZF,3)+((100*(CLOSE-REF(CLOSE,12))/REF(CLOSE,12))/2),5);

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,88))/(0.015*AVEDEV(TYP,88))/10,COLORGREEN;

M1:=EMA(C,13);

M2:=EMA(C,34);

A:((CROSS(RO, OKK) AND OKK>REF(OKK,1) AND OKK<8 AND C>M1 AND CCI>5

AND 势<5 AND 势>REF(势,1) AND RO>5 AND M1-M2<0.68

)OR (CROSS(RO,势)AND CROSS(RO, OKK) AND CROSS(势,OKK))AND CCI>5

AND CCI<18 AND 势>0 AND RO>5)

*4,COLORRED;

 通达信股海狂龙指标公式-通达信公式  神奇k线组合主图指标

神奇k线组合主图指标

DRAWTEXT(C>=O,H*1.02,VAR2STR((C-REF(C,1))/REF(C,1)*100,2)),COLORRED;DRAWTEXT(C

{神奇布林线主图} MID2 := MA(CLOSE,21),COLORWHITE; UPPER2:=MID2 + 1.96*STD(CLOSE,21),COLORYELLOW; LOWER2:=MID2 - 1.96*STD(CLOSE,21),.

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;J 评论0 0 0